FOL9000

Installationsprobleme bei älteren Magento-Versionen und neueren PHP-Versionen

nach | Keine Kommentare

Da wollte ich nur mal eben Magento 1.7.0.2 installieren, um etwas mit der älteren Version zu testen, da gibt es die (definitiv falsche) Fehlermeldung: „Database server does not support the InnoDB storage engine.“ Was soll das denn? Ich hatte das doch schon so oft installiert und jetzt das… Nicht lang nachdenken, erstmal googeln und schon gab es die Antwort.

Magento 1.7.0.2 verträgt sich nicht mit den PHP- und MySQL-Version einer aktuelleren XAMPP-Version. Konkret ist es hier PHP 5.5.x. Ich habe die Lösung nicht selbst erarbeitet, sondern bei
MageGyver gefunden. Die Problem-Ursachen und -Lösungen sind dort ausführlich beschrieben. Außerdem gibt es eine Extension auf GitHub, die das Problem behebt.

Vermutlich gibt es diverse Kombinationen von PHP- und Magento-Versionen, bei denen das Problem auftritt. Ich hab in der Überschrift deshalb bewusst keine konkreteren Versionsnummern genannt.

Schreibe einen Kommentar

Pflichtfelder sind mit * markiert.